This documentation is deprecated
Please see the new LoopBack documentation site.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

Dup lb article
URLhttp://loopback.io/doc/en/lb2/Installing-compiler-tools.html

div
styleborder: 1px solid #bbb; border-radius: 5px; padding: 10px; background-color: #f5f5f5; width: 400px; float: right;

Why do I need to install a compiler?

Some devops features such as monitoring and memory / CPU profiling require native (C++) code.  StrongLoop distributes its software with npm, but npm compiles native code upon installation.  Therefore, to take advantage of these features, you must install a compiler.

...

  • Python (v2.7 recommended; v3.x.x is not supported).  If you installed Python in a non-standard location, see Configuring Python directory.
  • make
  • A proper C/C++ compiler toolchain, like GCC.  NOTE: g++ version 4.2 or later is required.

...